Font Size

Notice body

All iOS devices should be updated as soon as possible. Even if the device does not have a notification of a pending updates, check for updates.

“A serious security breach was discovered on Apple's iOS this week that could leave your iPhone vulnerable to a remote jailbreak. Thursday afternoon, Apple issued an urgent iPhone and iPad software update, iOS 9.3.5, that includes a patch for the vulnerability. If you haven't already done so, you should install the new version immediately,” PJ Media reported.

More information about the security breach can be found online.